libquvi

Website, builds, or other suggestions.
Post Reply
DJX
Posts: 54
Joined: Mon Aug 06, 2012 10:37 pm

libquvi

Post by DJX » Tue Jul 02, 2013 6:25 pm

http://quvi.sourceforge.net/

FFmpeg supports this external library and I would like to try it out sometime.

Thanks.

DJX
Posts: 54
Joined: Mon Aug 06, 2012 10:37 pm

Re: libquvi

Post by DJX » Tue Feb 10, 2015 6:11 pm

Bump

rogerdpack
Posts: 1878
Joined: Fri Aug 05, 2011 9:56 pm

Re: libquvi

Post by rogerdpack » Fri Feb 13, 2015 4:34 pm

hmm this one looks tricky [dependency on lua? but how do you cross compile that? and then how static?] hmm...
If anybody figures it out please post back here for the rest of us to benefit :)
-roger-

qyot27
Posts: 84
Joined: Wed Jan 23, 2013 4:10 pm
Contact:

Re: libquvi

Post by qyot27 » Tue Feb 17, 2015 8:13 pm

libquvi is a waste of time. It won't work even with all the dependencies met, and it's not actively developed anymore. FFmpeg may not even be able to use the newer 0.9 branch (last commit in Nov 2013), but rather the 0.4 branch, meaning that the code is even older. The wrapper for it should quite honestly be removed from libavformat - when the libfaad wrapper was removed a number of years ago because its time had passed, it was still perfectly functional, just redundant; libquvi isn't really functional at all now.

At one time, it was kind of sort of okay, but most of the sites it supported can no longer be accessed with it...except maybe some of the porn ones, if you squint at them funny. And that was mostly when using it through mpv; FFmpeg was notoriously difficult to use libquvi with. Youtube absolutely cannot be viewed with libquvi anymore, so forget about that idea.

mpv also had its own separate libquvi integration for a time (and I did have instructions for it in my cross-compile guide while it was relevant; it required checking out/building from the 0.4 branch and performing sed work on the .pc.in file so it would link correctly with libcurl and librtmp), but these issues kept piling up and that's why they abandoned libquvi and implemented a bridge to use youtube-dl as a backend instead. youtube-dl is very actively developed in contrast, and has been for years.

The Lua part of the dependency chain is still in the guide (which is cleaner than it was in the libquvi days, since LuaDist exists now; I used to direct users at a tarball maintained by the MinGW devs, but LuaDist is more up-to-date):
https://github.com/qyot27/mpv/blob/extr ... s.txt#L625

Post Reply
'