Get rid of swscale output messages: "No accelerated ..."

For the developers that use FFmpeg in their software.
Post Reply
nota
Posts: 4
Joined: Tue Mar 06, 2012 9:27 am

Get rid of swscale output messages: "No accelerated ..."

Post by nota » Tue Mar 06, 2012 9:50 am

Hi,

I was just wondering if it was possible to get rid of swscale messages of "no accelerated colorspace conversion found" or, at least, get it only first time instead of every time the function sws_scale() is called, without recompiling ffmpeg (I get the message every frame!). I am using latest win32 binaries in ffmpeg.arrozcru.org/builds/ (revision 16537). Anyone knows if it is possible?

Thanks

ramiro
Posts: 157
Joined: Tue May 10, 2011 12:56 am

Re: Get rid of swscale output messages: "No accelerated ..."

Post by ramiro » Wed Mar 07, 2012 3:54 pm

did you read the big yellow and red warning on that page?

nota
Posts: 4
Joined: Tue Mar 06, 2012 9:27 am

Re: Get rid of swscale output messages: "No accelerated ..."

Post by nota » Fri Mar 09, 2012 9:23 am

Yes, but, if you are saying "updating will solve the issue", I don't think so. I have used newer versions of ffmpeg in other projects and always had that message. This is an old program, made with that version, and I just wanted to get rid of the messages making as few changes on it as possible.

If you can tell me that updating will solve it, I will, but the question is if anyone knows of an obvious way in swscale to disable messages which I could try straight forward.

Thanks anyway

Post Reply
'