Page 1 of 1

Unable to install ffmpeg-php on Ubuntu

Posted: Fri Apr 19, 2019 7:27 am
by ashokcool2636
I'm working on App where user can upload video in any format like mkv,flv,webm,mov,avi etc,so that need to convert various type of video format into mp4 video format,so that it will support in all devices for that I Want to use the ffmpeg on my server.
I downloaded FFmpeg (version 2.2.3) and compiled with --disable-yasm and --enable-shared configuration and installed.
I then downloaded ffmpeg-php extension from here - http://sourceforge.net/projects/ffmpeg- ... php/0.6.0/
I was able configure successfully.

phpize output:

Configuring for:
PHP Api Version: 20121113
Zend Module Api No: 20121212
Zend Extension Api No: 220121212

php --version output:

PHP 5.5.9-1ubuntu4.4 (cli) (built: Sep 4 2014 06:56:34)
Copyright (c) 1997-2014 The PHP Group
Zend Engine v2.5.0, Copyright (c) 1998-2014 Zend Technologies
with Zend OPcache v7.0.3, Copyright (c) 1999-2014, by Zend Technologies

Re: Unable to install ffmpeg-php on Ubuntu

Posted: Mon Apr 22, 2019 5:07 pm
by BiDouiLle
Hi AshOkCool2636,

Why using oldish versions of all your components ??!?

Regards.

--
Bidouille