Why won't this play on Apple players?

Questions involving a Windows version of FFmpeg.
Post Reply
giuseb
Posts: 2
Joined: Wed Oct 03, 2018 9:33 am

Why won't this play on Apple players?

Post by giuseb » Wed Oct 03, 2018 9:43 am

I generated a short movie from a stack of still PNGs, with no audio, like so:

Code: Select all

ffmpeg -r 24 -i t%03d.png -r 24 -c:v libx264 test.mp4
The resulting video plays fine with VLC and Chrome, but appears blank in iTunes and Final Cut Pro. Quicktime and Safari complain that the file is "not compatible". Here's the output of ffprobe:
ffprobe version 4.0.2 Copyright (c) 2007-2018 the FFmpeg developers
built with Apple LLVM version 9.1.0 (clang-902.0.39.2)
configuration: --prefix=/usr/local/Cellar/ffmpeg/4.0.2 --enable-shared --enable-pthreads --enable-version3 --enable-hardcoded-tables --enable-avresample --cc=clang --host-cflags= --host-ldflags= --enable-gpl --enable-libmp3lame --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265 --enable-libxvid --enable-opencl --enable-videotoolbox --disable-lzma
libavutil 56. 14.100 / 56. 14.100
libavcodec 58. 18.100 / 58. 18.100
libavformat 58. 12.100 / 58. 12.100
libavdevice 58. 3.100 / 58. 3.100
libavfilter 7. 16.100 / 7. 16.100
libavresample 4. 0. 0 / 4. 0. 0
libswscale 5. 1.100 / 5. 1.100
libswresample 3. 1.100 / 3. 1.100
libpostproc 55. 1.100 / 55. 1.100
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'test.mp4':
Metadata:
major_brand : isom
minor_version : 512
compatible_brands: isomiso2avc1mp41
encoder : Lavf58.12.100
Duration: 00:00:20.17, start: 0.000000, bitrate: 3918 kb/s
Stream #0:0(und): Video: h264 (High 4:4:4 Predictive) (avc1 / 0x31637661), yuvj444p(pc), 1600x1200 [SAR 1:1 DAR 4:3], 3916 kb/s, 24 fps, 24 tbr, 12288 tbn, 48 tbc (default)
Metadata:
handler_name : VideoHandler
Last edited by giuseb on Thu Oct 04, 2018 9:31 am, edited 2 times in total.

giuseb
Posts: 2
Joined: Wed Oct 03, 2018 9:33 am

Re: Why won't this play on Apple devices?

Post by giuseb » Thu Oct 04, 2018 9:30 am

I have found the answer here:
https://stackoverflow.com/questions/258 ... ack-screen
Cheers

StormFiber
Posts: 2
Joined: Thu Jan 17, 2019 3:26 pm

Re: Why won't this play on Apple players?

Post by StormFiber » Fri Jan 18, 2019 1:24 pm

Hi there, I found this thread while searching about this issue since I'm having the same thing happening.

That's a pretty terrible solution, since you basically lose all your data just to be able to play music with Apple Music again.

Is there really no other solution? No one else has had any luck with anything else? I've tried so many things and have not been able to get this to work either, except to setup my phone as new again. This is pretty ridiculous.

Post Reply
'