Wiki pages are no longer available, advice needed!

Questions involving a Windows version of FFmpeg.
rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: Wiki pages are no longer available, advice needed!

Post by rogerdpack » Fri Feb 01, 2013 5:36 am

Squeeto wrote:
ramiro wrote: You can use this opportunity to find out where the problem is (check configure, the makefiles and the ifdefs in the code) and send a patch to fix the issue.
Looks like Daniel Kang has submitted this already:
https://patches.libav.org/patch/34006/

<edit>
Sorry if this question is beyond the scope of this topic but how do I apply this patch to get past this?
unfortunately libav != ffmpeg so it may be awhile before those commits are pushed upstream (and I doubt if that's the one you need anyway). You might consider filing a http://ffmpeg.org/trac/ffmpeg describing you problem.

In the meantime I'd suggest disabling things one at a time to make things smaller, or just living with a 4MB executable :)
-r

Squeeto
Posts: 24
Joined: Thu Jan 31, 2013 1:06 am

Re: Wiki pages are no longer available, advice needed!

Post by Squeeto » Fri Feb 01, 2013 5:50 am

I copied the .patch file to ffmpeg-git and cd to ffmpeg-git

patch -p1 < v2-dsputil-x86-Convert-mpeg4-qpel-and-dsputil-avg-to-yasm.patch

...
33 out of 34 hunks FAILED -- saving rejects to file ...

:lol: Who let me play?

rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: Wiki pages are no longer available, advice needed!

Post by rogerdpack » Fri Feb 01, 2013 4:55 pm

Squeeto wrote:I copied the .patch file to ffmpeg-git and cd to ffmpeg-git

patch -p1 < v2-dsputil-x86-Convert-mpeg4-qpel-and-dsputil-avg-to-yasm.patch

...
33 out of 34 hunks FAILED -- saving rejects to file ...

:lol: Who let me play?
yeah that patch is for libav not ffmpeg, and it's unclear to me whether it would fix you problem anyway, see my previous message for current recommendation.

Squeeto
Posts: 24
Joined: Thu Jan 31, 2013 1:06 am

Re: Wiki pages are no longer available, advice needed!

Post by Squeeto » Fri Feb 01, 2013 9:57 pm

rogerdpack wrote: In the meantime I'd suggest disabling things one at a time to make things smaller...
Okay, so its working to here so far, with these added parameters to ./configure:
--disable-encoders --disable-muxers --disable-debug --disable-network --disable-hwaccels --disable-indevs --disable-outdevs --disable-parsers --enable-encoder=ac3 --enable-muxer=ac3 --enable-parser=ac3 --disable-bsfs

ffmpeg is still over 8M (before upx)
Am I missing a strip command of some kind?

Going to disable some of the decoders and demuxers next.

Let me know if I am turning this into my personal blog and I will stop posting. Just want to help the next Googler who finds this. Peace.

rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: Wiki pages are no longer available, advice needed!

Post by rogerdpack » Fri Feb 01, 2013 10:25 pm

Squeeto wrote:
rogerdpack wrote: In the meantime I'd suggest disabling things one at a time to make things smaller...
Okay, so its working to here so far, with these added parameters to ./configure:
--disable-encoders --disable-muxers --disable-debug --disable-network --disable-hwaccels --disable-indevs --disable-outdevs --disable-parsers --enable-encoder=ac3 --enable-muxer=ac3 --enable-parser=ac3 --disable-bsfs

ffmpeg is still over 8M (before upx)
Am I missing a strip command of some kind?

Going to disable some of the decoders and demuxers next.

Let me know if I am turning this into my personal blog and I will stop posting. Just want to help the next Googler who finds this. Peace.
ffmpeg_g should be the one with debug symbols.
Anyway, you might be able to look at your .o files that it ends up using to see which ones are still big...

ramiro
Posts: 157
Joined: Tue May 10, 2011 12:56 am

Re: Wiki pages are no longer available, advice needed!

Post by ramiro » Sat Feb 02, 2013 1:56 am

Squeeto wrote:
rogerdpack wrote: In the meantime I'd suggest disabling things one at a time to make things smaller...
Okay, so its working to here so far, with these added parameters to ./configure:
--disable-encoders --disable-muxers --disable-debug --disable-network --disable-hwaccels --disable-indevs --disable-outdevs --disable-parsers --enable-encoder=ac3 --enable-muxer=ac3 --enable-parser=ac3 --disable-bsfs

ffmpeg is still over 8M (before upx)
Am I missing a strip command of some kind?

Going to disable some of the decoders and demuxers next.
Disabling the decoders should free up many Mbs. You should start with --disable-everything and work your way up to only the things you need.
Squeeto wrote:Let me know if I am turning this into my personal blog and I will stop posting. Just want to help the next Googler who finds this. Peace.
I'd say this is the proper place for this =)

Squeeto
Posts: 24
Joined: Thu Jan 31, 2013 1:06 am

Re: Wiki pages are no longer available, advice needed!

Post by Squeeto » Sat Feb 02, 2013 7:20 am

ramiro wrote: You should start with --disable-everything and work your way up to only the things you need.
That's how I started but it threw a make error - undefined reference to 'ff_put_pixels8_mmxext'.
It's okay, I can remove them one by one.

Is there a way to do something like this:
./configure --get-parameters-from-text-file=myparams.txt

|know that I have the up arrow for this but ... just asking.

Squeeto
Posts: 24
Joined: Thu Jan 31, 2013 1:06 am

Re: Wiki pages are no longer available, advice needed!

Post by Squeeto » Sat Feb 02, 2013 5:13 pm

Squeeto wrote: Going to disable some of the decoders and demuxers next.
Adding --disable-decoders --enable-decoder=<video and audio decoders that I need>
brought back the original mmx error.

So I --disable-mmx --disable-mmxext and back to working 8-)

ffmpeg is just over 2M; diabling demuxers next.

Squeeto
Posts: 24
Joined: Thu Jan 31, 2013 1:06 am

Re: Wiki pages are no longer available, advice needed!

Post by Squeeto » Sat Feb 02, 2013 9:04 pm

demuxers gone

ffmpeg < 2M before upx

unneeded libs next

rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: Wiki pages are no longer available, advice needed!

Post by rogerdpack » Sat Feb 02, 2013 10:53 pm

Squeeto wrote:
Squeeto wrote: Going to disable some of the decoders and demuxers next.
Adding --disable-decoders --enable-decoder=<video and audio decoders that I need>
brought back the original mmx error.

So I --disable-mmx --disable-mmxext and back to working 8-)

ffmpeg is just over 2M; diabling demuxers next.
it may run slower with --disable-mmx ...

Post Reply
'