Why can ffmpeg3.2.2 not run on xp?

Questions involving a Windows version of FFmpeg.
Post Reply
dttlgotv
Posts: 11
Joined: Wed May 06, 2015 7:03 am

Why can ffmpeg3.2.2 not run on xp?

Post by dttlgotv » Wed Feb 15, 2017 10:00 am

I run the command line " ffmpeg.exe " in window xp using ffmpeg3.2.2.
The wrong hint will be see like "__wfopen_s can not found msvcrt.dll".

will ffmpeg not support on windows xp?

BiDouiLle
Posts: 58
Joined: Wed Oct 17, 2012 7:45 am
Location: Corsica

Re: Why can ffmpeg3.2.2 not run on xp?

Post by BiDouiLle » Fri Feb 17, 2017 4:55 pm

Hi dttlgotv,

Since a few time, the ffmpeg's build provided by Zeranoe is not anymore compatible with Windows XP.

You'll need to compile it yourself to ensure the compatibility.

I would rather upgrade Windows to version 10 as XP is full of security holes, not anymore updated since a long time by Microsoft.

palacs
Posts: 1
Joined: Tue Mar 14, 2017 7:59 pm

Re: Why can ffmpeg3.2.2 not run on xp?

Post by palacs » Tue Mar 14, 2017 8:24 pm

You don't need to recompile them because there are a lot of archived versions compatible with XP. These are also good for almost all of the common purposes and deal with various formats perfectly.

One of these builds is ffmpeg-20150525-git-8ce564e

If you have an old computer, it is not worth it to upgrade. Windows 7/8/10 will never be as fast as XP. Don't worry about security holes either, don't let the hysteria generated by the tech media come to your head. If you're not stupid, you'll be safe. Btw, use Opera 36, they still patch a version for XP.

llogan
Posts: 332
Joined: Fri Mar 14, 2014 3:29 am

Re: Why can ffmpeg3.2.2 not run on xp?

Post by llogan » Wed Apr 05, 2017 12:16 am

palacs wrote:One of these builds is ffmpeg-20150525-git-8ce564e
That's absolutely ancient. This thread has newer builds:
viewtopic.php?f=13&t=3572&p=12084&sid=8 ... 2ef#p12084

edumj
Posts: 6
Joined: Mon Apr 03, 2017 11:04 pm

Re: Why can ffmpeg3.2.2 not run on xp?

Post by edumj » Wed Apr 05, 2017 3:07 pm

Hi,
llogan wrote:
palacs wrote:One of these builds is ffmpeg-20150525-git-8ce564e
That's absolutely ancient. This thread has newer builds:
viewtopic.php?f=13&t=3572&p=12084&sid=8 ... 2ef#p12084
But this newer one doesn't have libxvid library.
palacs wrote:You don't need to recompile them because there are a lot of archived versions compatible with XP. These are also good for almost all of the common purposes and deal with various formats perfectly.

One of these builds is ffmpeg-20150525-git-8ce564e

If you have an old computer, it is not worth it to upgrade. Windows 7/8/10 will never be as fast as XP. Don't worry about security holes either, don't let the hysteria generated by the tech media come to your head. If you're not stupid, you'll be safe. Btw, use Opera 36, they still patch a version for XP.
And this from 2015 has that bug with ignoring bitrate at 2 pass enconding with libxvid (it always uses q2 for each frame!), which also happens in all latest builds since there! 2 pass enconding only works ok with 2014 versions, but I've just found another bug in that version which puts I frames 2 o 3 frames after a scene change! So, I can't use any of them to make XviD with 2 pass! Not with XP but neither with Windows 7! :cry:

And it seems that problem whit 2 pass only happens with windows compiled versions... :shock:

Post Reply