Windows server crashs in video transcode during

Questions involving a Windows version of FFmpeg.
Post Reply
parsasaei
Posts: 5
Joined: Sat Nov 05, 2016 11:19 am

Windows server crashs in video transcode during

Post by parsasaei » Sat Feb 09, 2019 6:40 am

I'm using ffmpeg for transcoding of my videos on a HP Blade dedicated server with these details:

OS: Windows Server 2012 R2 64Bit
CPU: Intel XEON X5650
RAM: 16GB
Hard disk: A sas normal disk

This command is a sample for creating qualities which has 4K as top level and I use this command for creating lower qualities from that as parallel at the same time.

Code: Select all

ffmpeg -i input.mp4 -filter_complex 
[0:v]split=4[s0][s1][s2][s3];
[s0]scale=uhd2160[v0];
[s1]scale=hd1080[v1];
[s2]scale=hd720[v2];
[s3]scale=hd480[v3];
[s4]scale=nhd[v4];
[s5]scale=cga[v5]
-map [v0] -map [v1] -map [v2] -map [v3] -map [v4] -map [v5] -map 0:a 
-c:v libx264 -c:a aac -f tee -g 48 -threads 0 
"[select='v\:0,a':f=hls:hls_list_size=0:hls_time=6]../video/2160p/out.m3u8| 
 [select='v\:1,a':f=hls:hls_list_size=0:hls_time=6]../video/1080p/out.m3u8| 
 [select='v\:2,a':f=hls:hls_list_size=0:hls_time=6]../video/720p/out.m3u8| 
 [select='v\:3,a':f=hls:hls_list_size=0]../video/480p/out.m3u8| 
 [select='v\:3,a':f=hls:hls_list_size=0:hls_time=6]video/360p/out.m3u8| 
 [select='v\:3,a':f=hls:hls_list_size=0:hls_time=6]video/200p/out.m3u8"
Some times in transcoding time windows goes to reconnecting and count up to 20 and then goes to black screen. I cannot find anythings in windows logs. And finally I restart server from button of that server. What's hapenning? How can I find a clue, about this issue?
Any one know anything about this issue?

Post Reply