libvpx_vp9 encoder is not being considered with the below flags

Questions that occur when trying to compile FFmpeg.
Post Reply
srivathsa
Posts: 1
Joined: Sun Nov 18, 2018 2:31 pm

libvpx_vp9 encoder is not being considered with the below flags

Post by srivathsa » Sun Nov 18, 2018 2:39 pm

I have compiled libvpx library with the below flags
./configure --disable-examples --disable-extra-warnings --disable-docs --disable-unit-tests --disable-vp8 --disable-avx --enable-vp9-highbitdepth

When I try to statically link libvpx to ffmpeg, I am able to see it in decoders and parsers but not as part of the encoders. The below command is what I am using to compile ffmpeg
PKG_CONFIG_PATH=/root/lib/pkgconfig ./configure --enable-libvpx --enable-encoder=libvpx_vp9 --enable-static --extra-cflags="-I/root/libvpx/include" --extra-ldflags="-L/rootr/libvpx/lib -static-libgcc -static" --disable-ffplay --disable-doc --disable-htmlpages --disable-x86asm --prefix=/root/video_converter/ffmpeg

The issue is seen only in the latest version. When I try compiling 3.4.2 with the same command with cflags as -I/root/libvpx/include/vpx, it takes vp9 in encoders.
Is there any specific flags that need to be added here.
Thanks for the help.

Post Reply