Page 1 of 1

ffmpeg configure error: ERROR: libx264 must be installed and version must be >= 0.118.

Posted: Wed Feb 21, 2018 1:18 pm
by questhk09
Hi,

The original subject: ffmpeg install error: ‘AVComponentDescriptor’ has no member named ‘depth’

I'm trying to install ffmpeg to centOS6 server and am having hard time to do it.

1. Yasm (compile & install)
2. libx264 (compile & install)
3. libfaac (compile & install)
4. ffmpeg (compile & install)

When I tried "make" of 2 I had an error like below.

filters/video/resize.c:215: error: ‘AVComponentDescriptor’ has no member named ‘depth’

Could you tell me what to do with this?

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

I somehow managed to solve this error by applying the method discussed this site.

https://blog.hostonnet.com/error-we-got ... n-centos-7

Re: ffmpeg configure error: ERROR: libx264 must be installed and version must be >= 0.118.

Posted: Fri Feb 23, 2018 12:56 am
by questhk09
Now, I'm facing a new problem when I tried to configure ffmpeg like below.

[[email protected] ffmpeg-2.2.2]# ./configure --prefix=/usr/local/src/f2 --disable-ffplay --disable-ffserver --disable-shared --enable-static --enable-gpl --enable-libx264 --enable-libfaac --enable-nonfree --extra-cflags="-I/usr/local/src/f2/include" --extra-ldflags="-L/usr/local/src/f2/lib"

ERROR: libx264 must be installed and version must be >= 0.118.


I've searched around the entire search engine to look for the answer of the similar case, but I've not found yet, or maybe can not anymore.

Could anyone help me out this?