ERROR vidstab 0.98 not found using pkg-config

Questions that occur when trying to compile FFmpeg.
Post Reply
Bassquake
Posts: 4
Joined: Thu Jun 27, 2019 8:56 am

ERROR vidstab 0.98 not found using pkg-config

Post by Bassquake »

Having a bit of an issue with adding libraries to compile ffmpeg with.

Im trying to add the stablisation plug in vidstab for example.

I've compiled and installed the library and pkg-config reports it can be found fine:

Code: Select all

$ pkg-config --exists --print-errors vidstab && echo $?
0
But when i do (currently building a cuda based ffmpeg):

Code: Select all

 ./configure --enable-cuda-nvcc --enable-cuvid --enable-nvenc --enable-nonfree --extra-cflags="-I./nv_sdk/include -I./frei0r/include -I/mingw64/include" --extra-ldflags="-L./nv_sdk/lib/x64 -L/mingw64/lib" --enable-gpl --enable-libnpp --enable-avisynth --enable-frei0r --enable-version3 --enable-gmp --enable-libvidstab
The error is:

Code: Select all

ERROR: vidstab >= 0.98 not found using pkg-config
The PKG_CONFIG_PATH are all pointing to the correct place:

Code: Select all

$ echo $PKG_CONFIG_PATH
/usr/local/lib/pkgconfig:/mingw64/lib/pkgconfig:/usr/lib/pkgconfig
Library path looks correct (libvidstab.so is in there):

Code: Select all

$ pkg-config --libs vidstab
-L/usr/local/lib -lvidstab -lm -lgomp
ffmpeg compiles fine if I dont add the --enable-libvidstab.

Not sure what else to try, so any ideas appreciated!

Edit: Using msys64 on Windows 10.

Edit 2: config.log:

https://controlc.com/a47adc04

rogerdpack
Posts: 1883
Joined: Fri Aug 05, 2011 9:56 pm

Re: ERROR vidstab 0.98 not found using pkg-config

Post by rogerdpack »

Check your config.log file, see what it says.
This helper cross compiles it OK so it should be possible (mine anyway):
https://github.com/rdp/ffmpeg-windows-build-helpers

Post Reply