Page 1 of 1

Adding lensfun support

Posted: Tue Jul 31, 2018 2:37 pm
by BlackScreen
Would it be possible to add support for the new lensfun filter which allows the use of lens correction.
Thanks for considering!

Re: Adding lensfun support

Posted: Tue Aug 14, 2018 2:42 am
by Zeranoe
Lensfun requires Glib to compile (no idea why). This would likely add a massive size to the binaries.

That being said, I will do some testing and see how much it does add.

Re: Adding lensfun support

Posted: Thu Aug 16, 2018 2:53 pm
by hydra3333
Thank you !

Re: Adding lensfun support

Posted: Thu Aug 16, 2018 7:03 pm
by Zeranoe
I built gettext, libffi, glib (which was a horrible experience), and finally lensfun .

I ran into a bug running Lensfun though: https://trac.ffmpeg.org/ticket/7358

Hopefully working support will be available soon.

Re: Adding lensfun support

Posted: Fri Aug 17, 2018 4:01 am
by hydra3333
Zeranoe wrote:
Thu Aug 16, 2018 7:03 pm
I built gettext, libffi, glib (which was a horrible experience), and finally lensfun .
Yes, I am finding that too. Does it need pcre ? Being a non-linux person, I have an unsubstantiated feeling that a couple of things may need some matching combination of

Code: Select all

https://github.com/Alexpux/MINGW-packages/blob/master/mingw-w64-glib2/0001-glib2-mr-226.patch # for glib2
-D_FILE_OFFSET_BITS=64 
'CFLAGS'   : '-D_FILE_OFFSET_BITS=64 ',
'CXXFLAGS' : '-D_FILE_OFFSET_BITS=64 ',
Zeranoe wrote:
Thu Aug 16, 2018 7:03 pm
I ran into a bug running Lensfun though: https://trac.ffmpeg.org/ticket/7358
Hopefully working support will be available soon.
Thank you.
Once you have it, would you be able to share the configures/makes/patches for this stuff ?