What happened with libxvid??

Website, builds, or other suggestions.
Post Reply
edumj
Posts: 6
Joined: Mon Apr 03, 2017 11:04 pm

What happened with libxvid??

Post by edumj » Sat Jan 20, 2018 4:41 pm

Hi,

I just uploaded to the lastest version, and when I try to encode to XVID it says "Unknown encoder 'libxvid'. :shock:

I don't know since when it happens, because until yesterday I was using a very old version, but it seems it's no longer build with --enable-libxvid --enable-gpl ??

Thanks.

User avatar
Zeranoe
Site Admin
Posts: 702
Joined: Sat May 07, 2011 7:12 pm
Contact:

Re: What happened with libxvid??

Post by Zeranoe » Sat Jan 20, 2018 11:37 pm

The internal MPEG-4 encoder produces better results than Xvid, I would advise using that instead.

hydra3333
Posts: 195
Joined: Sun Apr 28, 2013 1:03 pm
Contact:

Re: What happened with libxvid??

Post by hydra3333 » Sun Jan 21, 2018 3:57 am

A dummy question, would that be -c:v libx264 ?

edumj
Posts: 6
Joined: Mon Apr 03, 2017 11:04 pm

Re: What happened with libxvid??

Post by edumj » Sun Jan 21, 2018 5:25 pm

Zeranoe wrote:
Sat Jan 20, 2018 11:37 pm
The internal MPEG-4 encoder produces better results than Xvid, I would advise using that instead.
I disagree with that, I did some tests and libxvid looks much better than internal mpeg-4 encoder. Also internal MPEG-4 encoder is less compatible with standalone players than libxvid.

But, why it's no longer included in your builds? I've tried older versions, and it was still included untill last september versions.

User avatar
Zeranoe
Site Admin
Posts: 702
Joined: Sat May 07, 2011 7:12 pm
Contact:

Re: What happened with libxvid??

Post by Zeranoe » Mon Jan 22, 2018 10:31 pm

Xvid has been added back in.

edumj
Posts: 6
Joined: Mon Apr 03, 2017 11:04 pm

Re: What happened with libxvid??

Post by edumj » Sat Jan 27, 2018 4:47 pm

Zeranoe wrote:
Mon Jan 22, 2018 10:31 pm
Xvid has been added back in.
Thanks!

Post Reply