Page 5 of 5

Re: Intel QSV Codecs

Posted: Thu Sep 07, 2017 12:12 pm
by TankBo
Has anyone found a fix for this? I have 2 laptops that have Intel i series processors with integrated graphics. The laptop that has HD3000 graphics/ Core i5 - 2520M processor I get the following error:

[h264_qsv @ 000000000030ece0]
Error initializing the encoder: invalid video parameters (-15)
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height
Conversion failed!

when I run the same command on my other laptop that has HD5500 graphics/ Core i7 - 5600U it runs successfully. Here is the command that I'm trying to run:

ffmpeg.exe -y -i "C:\video\test1.ts" -c:v h264_qsv -b:v 3072k -maxrate 4608k -bufsize 6912k -look_ahead 0 -c:a copy -f mp4 "C:\video\1.mp4"


On a side note when I run the benchmark command it runs successfully on both machines and I get around 9x to 10x performance. This is the benchmark command that runs on both machines.

ffmpeg.exe -hwaccel qsv -threads 1 -i "C:\video\test1.ts" -f null - -benchmark

Re: Intel QSV Codecs

Posted: Wed Sep 13, 2017 2:18 am
by AlcyonaHaramix
TO >>> TankBo :

,

for testing... just try this command... from this ( message / forum post ) ... > viewtopic.php?p=12043#p12043 < ... maybe itll work for you...

,

also... for your ( Core i5 - 2520M ) processor... try this REMIX-ed command...

Code: Select all


\ffmpeg.exe -i input_file_itself.mp4 -loglevel debug -pix_fmt nv12 -c:v h264_qsv -async_depth 4 -preset veryslow -bitrate_limit 1 -look_ahead 0 -b:v 3834000 -maxrate 3834000 -bufsize 4474111 -c:a copy -y output_file_itself.mp4

maybe itll work for your ( Core i5 - 2520M ) processor...

,

Re: Intel QSV Codecs

Posted: Mon Sep 18, 2017 11:23 pm
by TankBo
I wish that worked, but it didnt...

Error initializing the encoder: invalid video parameters (-15)
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as
bit_rate, rate, width or height
[AVIOContext @ 0000000002eb11e0] Statistics: 0 seeks, 0 writeouts
[AVIOContext @ 0000000000398de0] Statistics: 6312080 bytes read, 2 seeks
Conversion failed!

Re: Intel QSV Codecs

Posted: Thu Nov 30, 2017 8:33 am
by AlcyonaHaramix
TankBo wrote:
Mon Sep 18, 2017 11:23 pm
I wish that worked, but it didnt...

Error initializing the encoder: invalid video parameters (-15)
Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as
bit_rate, rate, width or height
[AVIOContext @ 0000000002eb11e0] Statistics: 0 seeks, 0 writeouts
[AVIOContext @ 0000000000398de0] Statistics: 6312080 bytes read, 2 seeks
Conversion failed!
,

ok... i have made an CBR command... aka >>> [h264_qsv @ 000000000252ac20] Using the constant bitrate (CBR) ratecontrol method

just copy and paste this command... and run it on your ( Core i5 - 2520M ) processor...

and if any error... show the ERROR ITSELF from FFMPEG ...

,

the command , ( run it on your ( Core i5 - 2520M ) processor ) ,

Code: Select all


\ffmpeg.exe -i input_file_itself.mp4 -loglevel debug -pix_fmt nv12 -c:v h264_qsv -async_depth 4 -avbr_accuracy 0 -avbr_convergence 0 -preset veryslow -vcm 0 -bitrate_limit 1 -cavlc 0 -idr_interval 0 -pic_timing_sei 1 -max_dec_frame_buffering 0 -look_ahead 0 -look_ahead_depth 0 -look_ahead_downsampling off -trellis:v P -profile:v high -b:v 3834000 -g 74 -bf 2 -slices 1 -refs 3 -b_strategy 1 -flags +cgop -a53cc 0 -maxrate 3834000 -bufsize 4474111 -sample_fmt s16p -compression_level 10 -c:a libmp3lame -b:a 224000 -ar 44100 -ac 2 -joint_stereo false -reservoir true -abr false -y output_file_itself.mp4

,

the options that i have changed

Code: Select all


Reading option '-async_depth' ... matched as AVOption 'async_depth' with argument '4'

Reading option '-look_ahead' ... matched as AVOption 'look_ahead' with argument '0'

Reading option '-look_ahead_depth' ... matched as AVOption 'look_ahead_depth' with argument '0'

Reading option '-maxrate' ... matched as AVOption 'maxrate' with argument '3834000'

,

the above ffmpeg command... executes QSV engine... with the following options... aka >>> [h264_qsv @ 000000000252ac20] Using the constant bitrate (CBR) ratecontrol method

Code: Select all


[h264_qsv @ 000000000252ac20] Initialized an internal MFX session using hardware accelerated implementation

[h264_qsv @ 000000000252ac20] Using the constant bitrate (CBR) ratecontrol method

,

[h264_qsv @ 000000000252ac20] profile: high level: 31

[h264_qsv @ 000000000252ac20] GopPicSize: 74 GopRefDist: 3 GopOptFlag: closed IdrInterval: 0

[h264_qsv @ 000000000252ac20] TargetUsage: 1 RateControlMethod: CBR

[h264_qsv @ 000000000252ac20] InitialDelayInKB: 3355 TargetKbps: 3834 MaxKbps: 3834

[h264_qsv @ 000000000252ac20] NumSlice: 1 NumRefFrame: 3

[h264_qsv @ 000000000252ac20] RateDistortionOpt: OFF

[h264_qsv @ 000000000252ac20] RecoveryPointSEI: OFF IntRefType: 0 IntRefCycleSize: 0 IntRefQPDelta: 0

[h264_qsv @ 000000000252ac20] MaxFrameSize: 345600 MaxSliceSize: 0

[h264_qsv @ 000000000252ac20] BitrateLimit: ON MBBRC: OFF ExtBRC: unknown

[h264_qsv @ 000000000252ac20] Trellis: P

[h264_qsv @ 000000000252ac20] RepeatPPS: ON NumMbPerSlice: 0 LookAheadDS: off

[h264_qsv @ 000000000252ac20] AdaptiveI: unknown AdaptiveB: unknown BRefType: pyramid

[h264_qsv @ 000000000252ac20] MinQPI: 0 MaxQPI: 0 MinQPP: 0 MaxQPP: 0 MinQPB: 0 MaxQPB: 0

[h264_qsv @ 000000000252ac20] Entropy coding: CABAC MaxDecFrameBuffering: 3

[h264_qsv @ 000000000252ac20] NalHrdConformance: ON SingleSeiNalUnit: ON VuiVclHrdParameters: OFF VuiNalHrdParameters: ON

,

just try it... maybe , THIS TIME , itll work for you...

,

Re: Intel QSV Codecs

Posted: Wed Jan 03, 2018 5:59 am
by AlcyonaHaramix
TO >>> TankBo :

hey guess what... i have been thinking about that... your ( Core i5 - 2520M ) processor... is too old for QSV engine...

and here is the interesting part...

-- we should somehow check >>> what RATE CONTROL MODES are supported on your ( Core i5 - 2520M ) processor...

and for doing this... aka > check >>> what RATE CONTROL MODES are supported on your ( Core i5 - 2520M ) processor...

-- you should download an old version of OBS from here > https://github.com/jp9000/OBS/releases/ ... 0_659b.zip < and run it...

ok... here goes... the full and long instruction... on... what you should do with old version of OBS ...

,

-- 1) -- you run an old version of OBS from this directory \OBS_0_659b\64bit\OBS.exe

-- 2) -- go to SETTINGS

-- 3) -- go to ENCODING tab

-- 4) -- inside of ENCODING tab select QUICK SYNC and hit APPLY > ((( !! SORRY !! - !! SCREENSHOT WONT BE PROVIDED !! )))

-- 5) -- go to QUICK SYNC ENCODER tab

-- 6) -- inside of QUICK SYNC ENCODER tab select USE CUSTOM PARAMETERS FOR THE QUICK SYNC ENCODER and hit APPLY > ((( !! SORRY !! - !! SCREENSHOT WONT BE PROVIDED !! )))

-- 7) -- make a screenshot of the QUICK SYNC ENCODER tab > ((( !! SORRY !! - !! SCREENSHOT WONT BE PROVIDED !! )))

-- 8) -- post here ( to this thread ) ... a link to your screenshot... that is... your screenshot of the QUICK SYNC ENCODER tab > ((( !! SORRY !! - !! SCREENSHOT WONT BE PROVIDED !! )))

,

this way we should know... what RATE CONTROL MODES are supported on your ( Core i5 - 2520M ) processor...

and... if the situation goes really ( blEAk ) or ( blACk ) lol... that is... NONE of the RATE CONTROL MODES are available to your ( Core i5 - 2520M ) processor...

then your only option would be... to upgrade your hardware... from ( Core i5 - 2520M ) to something newer...