Page 6 of 6

Re: DeckLink output --enable-decklink

Posted: Fri Aug 18, 2017 2:38 pm
by cedric75018
Hello ! It seems that the --enable-decklink is not present anymore in latest releases :(, do you know where I can find a recent Windows build with the decklink support ? Thank you for your help !!!

Re: DeckLink output --enable-decklink

Posted: Fri Aug 18, 2017 4:39 pm
by Zeranoe
Unfortunately Decklink cannot be included due to licensing issues. You'll have to build FFmpeg yourself, and there are many scripts available to assist with this.

Re: DeckLink output --enable-decklink

Posted: Mon Aug 21, 2017 1:28 pm
by cedric75018
Hello Zeranoe,

Thank you for your help ! I tried to compile FFmpeg with the decklink support but... it seems that FFmpeg can't adress the RGB pin of the capture card, which leads to a blackscreen when capturing :(.

When I start the command line, FFmpeg tells me that the detected stream is yuv422p10le (with -bm_v210 1), I can also ask for a uyvy422 with -bm_v210 is set to 0 but... impossible to ask for the RGB/444 Stream.

It seems that someone already experienced that issue : https://ffmpeg.org/pipermail/ffmpeg-dev ... 70520.html

Re: DeckLink output --enable-decklink

Posted: Tue Aug 22, 2017 8:47 am
by cedric75018
Hello again,

I did a new experiment to find out what's going on in FFmpeg with RGB capture :).

The idea was to inject a pure 4:2:2 video signal into the Intensity Pro 4K and try to capture it with the -decklink tag of the same version of FFmpeg than before, just to show if it is something related to FFmpeg in general or to the RGB feature only.

To do that I use a Blackmagic HDMI to SDI converter that only outputs 4:2:2 video, and then, I re-inject this video in my Intensity Pro 4K capture card (I need to use an intermediate video capture card to convert SDI to HDMI for the Intensity Pro 4K as I don't have SDI to HDMI converter).

You can have a look at the full setup in the picture attached.

Then I tried to capture this signal both ways. First, using -decklink tag and a FFmpeg compiled with the --enable-decklink and then using -dshow on a standard FFmpeg build. Here are the command lines :

ffmpeg.exe -f decklink -bm_v210 1 -format_code "hp60" -i "Intensity Pro 4K" -r 60 -vcodec copy -acodec copy output.avi

ffmpeg.exe -rtbufsize 1500M -f dshow -s 1280x720 -r 60 -i video="Decklink Video Capture (2)":audio="Decklink Audio Capture (2)" -vcodec copy -acodec copy output.avi

It is working in both cases (with 4:2:2 input):).

Of course, if I connect the source directly to the Intensity Pro 4K (RGB) it is not working (I got only black video captured).

Re: DeckLink output --enable-decklink

Posted: Thu Nov 09, 2017 2:14 pm
by sirfnomi
Zeranoe wrote:
Fri Aug 18, 2017 4:39 pm
Unfortunately Decklink cannot be included due to licensing issues. You'll have to build FFmpeg yourself, and there are many scripts available to assist with this.
Hi please help me in compiling ffmpeg with decklink
i'm getting error "ERROR: decklinkapi.h header not found"
i copy DecklinkAPI.h file to livavdevice folder but still i'm getting this error
i'm compiling ffmpeg from mingW with these commands
configure --prefix=/ffmpeg --enable-shared --enable-gpl --enable-nonfree --disable-w32threads --enable-version3 --disable-debug --disable-yasm --enable-libmp3lame --enable-libopus --enable-libvorbis --enable-libvpx --enable-libx264 --enable-decklink

Re: DeckLink output --enable-decklink

Posted: Thu Sep 27, 2018 2:51 am
by rogerdpack
It needs to go in your gcc's nclude folder or your manual include path like -I./myinclude ... also for followers I found a place with up to date headers https://notabug.org/RiCON/decklink-headers

Re: DeckLink output --enable-decklink

Posted: Wed Apr 03, 2019 5:28 am
by imorrish
Simple way to build ffmpeg with Decklink support on Windows 10

thanks to a couple of git repositories (one for ffmpeg and the other for decklink api files and a bash script). I have posted instructions with screenshots at https://ianmorrish.wordpress.com/2019/0 ... or-windows but have included basic steps below:
  • Enable the Windows Subsystem for Linux optional component (Control panel, Programs and Features, Turn Windows features on or off.)
    • Go to the Windows Store app and search for Ubuntu and install it.
    • Start Ubuntu from Windows command the type the following commands (some will take a long time)
    • sudo apt-get update
    • sudo apt-get install subversion ragel curl texinfo g++ bison flex cvs yasm automake libtool autoconf gcc cmake git make pkg-config zlib1g-dev mercurial unzip pax nasm gperf autogen bzip2 autoconf-4 archive p7zip-full python3-distutils -y
    • mkdir ffmpeg
    • cd ffmpeg
    • cd ffmpeg-windows-build-helpers
    • sudo ./cross_compile_ffmpeg.sh –disable-nonfree=n
    • Wait a very long time (hours) and if you get a good result there will be messages about where to find the files
    • cd /sandbox/cross_compilers/mingw-w64-x86_64/x86_64-w64-mingw32/
    • cp bin/* /mnt/c/ffmpeg/
    • Now you should see the files in Windows Explorer under c:\ffmpeg