How to Compile RTMPDump on Windows

Steam recording with RTMPDump or FFmpeg.
Post Reply
Posts: 1
Joined: Sun Jun 22, 2014 3:31 am

How to Compile RTMPDump on Windows

Post by quickie » Sun Jun 22, 2014 4:15 am

I've been using this guide ... on-windows to try to compile since it seems to be the latest and has the most specific instructions I found but I'm having some issues. I am currently using MingGW installation version 0.6.2 with msys-base, mingw-developer-tool, and mingw32-base packages installed. Also using openssl-1.0.1e (tried 1.0.1h latest too but failed) and zlib 1.2.5. However, when I tried to compile with

Code: Select all

make SYS=mingw
, I get

Code: Select all

mingw/bin/id.exe: cannot find -lz
I got around this by installing the dev libz 1.2.8 package in mingw and it compiled. But when I tried the program, I get an error popup

Code: Select all

rtmpdump.exe - Entry Point Not Found. 
The procedure entry point CRYPTO_memcmp could not be located in the dynamic link library LIBEAY32.dll
Does anyone know what I am doing wrong or have different steps to compile rtmpdump?


Posts: 1872
Joined: Fri Aug 05, 2011 9:56 pm

Re: How to Compile RTMPDump on Windows

Post by rogerdpack » Thu Jul 10, 2014 2:37 pm

make sure it installs "libz.a" file appropriately. Also you can cross compile it if desired: does it now.

Post Reply