Token invalid or expired from m3u8 manifest

Steam recording with RTMPDump or FFmpeg.
Post Reply
Posts: 1
Joined: Mon Feb 26, 2018 5:33 pm

Token invalid or expired from m3u8 manifest

Post by mrswhite »


I'm trying to download the video from this page: ... in-freeman

I am able to extract the m3u8 from the playlist:
playlist: ... gA3TOBcJPh

m3u8 with the desired resolution: ... gA3TOBcJPh

I get the same error trying to use either m3u8 files:

D:\tmp\ffmpeg\bin>ffmpeg.exe -i ... gA3TOBcJPh -c copy output.mp4

ffmpeg version N-81256-gd3426fb Copyright (c) 2000-2016 the FFmpeg developers
built with gcc 5.4.0 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-dx
va2 --enable-libmfx --enable-nvenc --enable-avisynth --enable-bzlib --enable-lib
ebur128 --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --ena
ble-libass --enable-libbluray --enable-libbs2b --enable-libcaca --enable-libfree
type --enable-libgme --enable-libgsm --enable-libilbc --enable-libmodplug --enab
le-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-lib
openjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-lib
snappy --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame
--enable-libvidstab --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx
--enable-libwavpack --enable-libwebp --enable-libx264 --enable-libx265 --enable-
libxavs --enable-libxvid --enable-libzimg --enable-lzma --enable-decklink --enab
libavutil 55. 28.100 / 55. 28.100
libavcodec 57. 51.100 / 57. 51.100
libavformat 57. 44.100 / 57. 44.100
libavdevice 57. 0.102 / 57. 0.102
libavfilter 6. 49.100 / 6. 49.100
libswscale 4. 1.100 / 4. 1.100
libswresample 2. 1.100 / 2. 1.100
libpostproc 54. 0.100 / 54. 0.100
[http @ 02f67f40] HTTP error 403 token is invalid or expired ... .m3u8?PR=E: Server returned 403 Forbidden (access denied)

"S" no se reconoce como un comando interno o externo, programa o archivo por lotes ejecutable. -> also it seems to not like the S parameter in the URL.

Could you help me out? I'm copying the m3u8 url to the command line as soon as i get it. I'm guessing maybe it doesn't like the command line headers cause they are not from the browser? That's only a guess as i don't understand what else could be going on.

I tried downloading the segments (.ts files) and merge them but that doesn't work either, probably encoded?

Thank you in advance.

User avatar
Site Admin
Posts: 705
Joined: Sat May 07, 2011 7:12 pm

Re: Token invalid or expired from m3u8 manifest

Post by Zeranoe »

i prefer youtube-dl for these sorts of things, which has no problem grabbing this.

youtube-dl uses FFmpeg on the back end, so it should work fine without it. You need to update your FFmpeg.

Post Reply