streaming with VLC & BlackMagic Intensity Pro card

Steam recording with RTMPDump or FFmpeg.
Post Reply
steebu
Posts: 2
Joined: Wed Feb 05, 2014 5:20 pm

streaming with VLC & BlackMagic Intensity Pro card

Post by steebu » Wed Feb 05, 2014 5:25 pm

Hi,

we purchased several BlackMagic Intensity Pro cards and would eventually like to stream and record the video using ffmpeg. At the moment, we can't even walk, let alone run.

I've installed the latest drivers (9.8) and software for the BM card.

If I use their Media Express software I can see the input video coming in over the HDMI input port (720p @ 59.94)

If I try to use ffplay or VLC I get the right frame size but a black screen. I even tried XSplit and I again get the right aspect ratio but only black input. I've seen others successfully stream using VLC or ffmpeg, so I'm not quite sure what's going on.

For what it's worth, both XSplit and VLC report the device: DeckLink Video Capture.
ffprobe outputs: Stream #0:0: Video: rawvideo (UYVY / 0x59565955), uyvy422(tv), 1280x720, 50
tbr, 10000k tbn, 50 tbc

so it's seeing "something" ... I just can't get anything other than their software to display something other than black video.

I've read through numerous posts and have tried just about everything ... I'm pretty sure that it will work based on this post:

http://stackoverflow.com/questions/1921 ... 20p-from-d

but as I mentioned, I see nothing but black video ... :-( Any suggestions?

User avatar
Zeranoe
Site Admin
Posts: 699
Joined: Sat May 07, 2011 7:12 pm
Contact:

Re: streaming with VLC & BlackMagic Intensity Pro card

Post by Zeranoe » Fri Feb 07, 2014 5:19 am

Please read: http://ffmpeg.zeranoe.com/forum/viewtop ... agic#p3415

I can provide more information if you have questions.

steebu
Posts: 2
Joined: Wed Feb 05, 2014 5:20 pm

Re: streaming with VLC & BlackMagic Intensity Pro card

Post by steebu » Fri Feb 07, 2014 5:54 pm

So a quick update:

- the input video stream to the BlackMagic card is 720p 59.94
- if I set the "Set default video standard as:" dropdown to HD 720p 59.94 I can view the stream with VLC and ffplay by specifying -i video="Blackmagic WDM Capture"
- if I set the "Select input processing:" dropdown to (Downconversion from HD to SD) 720p to SD Anamorphic 16:9 I can see the input in ffplay by specifying -i video="Decklink Video Capture". Any other setting (including "Off" for no processing) results in black video.

So ... it seems like the "Set default video standard" goes with Blackmagic WDM Capture, and "Select input processing" goes with Decklink Video Capture. It seems odd?

There's two problems now:

1. if I use ffmpeg to capture the stream and use -i video="Blackmagic WDM Capture" the process hangs when I hit 'q' (normally it stops capture, right?). I can only break out by hitting Ctrl-Break. But it records 720p 59.94 video and I can see it.
2. if I use ffmpeg to capture the stream and use -i video="Decklink Video Capture" then I can record the stream and hit 'q' and stop normally - it functions as it should. But the problem is that I cannot get any video stream other than the 720p HD to SD Anamorphic 16:9 converted video (size 720x486) - and I'd like to record the 720p stream.

One other thing to note - I have to specify rtbufsize 1500M otherwise I get all kinds of "real-time buffer 121% full! frame dropped!" messages, so hope that might help someone else.

Post Reply