VS 2012 and CUDA - typedefs become undefined

For the developers that use FFmpeg in their software.
Post Reply
Posts: 1
Joined: Sat Aug 05, 2017 2:26 pm

VS 2012 and CUDA - typedefs become undefined

Post by byrnespd »

I just downloaded the developer version of 3.3.2 x64 from the main page.

Some preliminary info:
- I'm using Win7 x64
- I'm using CMake to generate a C++ VS 2012 solution for a big school project (dissertation related)
- I use a bunch of different libraries, but the main offender for compatibility issues seems to be CUDA 6.5
- Due to an older NVidia Quadro 4000 card, I have to use CUDA 6.5 (no wiggle room)
- Project builds successfully and has for years
- I hate working with CUDA video decoding and the software I've written around it is clunky - but, it works
- I'm looking for a different solution for video handling, and FFmpeg is mentioned all over

Adding FFmpeg:
- I unpacked the download to my libraries repository and acquired what seems to be a reasonable FindFFMPEG cmake config file
- Added my directories to it and the solution is generated just fine

Building the project:
- Again, with FFmpeg commented, everything builds clean as before
- As soon as I used the generated solution with FFmpeg, CUDA goes nuts and all its typedefs go undefined
- For example, clock_t becomes undefined
- I tried putting the find_package(FFMPEG) elsewhere in the project CMake in case there was some kind of order issue, though I didn't expect that to work... and, it didn't.

Anyway, does anybody have any clue as to what the conflict might be? I'm assuming I'll have to attempt to build FFmpeg on my machine, though I have tried before and failed. I know this isn't a huge amount to go on, but any thoughts, suggestions, how-to's for building windows-based FFmpeg for VS2012, etc. would be greatly appreciated.


Post Reply