Capture problem in 256 color / palette mode

Any other question that don't fit into the other support categorizes.
Post Reply
prux
Posts: 3
Joined: Sun Nov 13, 2011 8:36 pm

Capture problem in 256 color / palette mode

Post by prux »

hey, I hope I will post to the right topic :D

I successfully tried and used a screen capturer plugin (UScreenCapture) with FFmpeg, but I have an application which I cant capture. Its a 256 palette colored, full screen application (Worms Armageddon). The plugin records fine, but in case of this program, it can only record black screen, or later it cant handle the colors properly.

the way I use it:

ffmpeg -f dshow -i video="UScreenCapture" -r 30 -vcodec mpeg4 -q 12 -f mpegts test.avi

and the result:

http://www.youtube.com/watch?v=zv3Cvj_IOB0

what can be the error? How to capture then?
Thx in advance

ramiro
Posts: 157
Joined: Tue May 10, 2011 12:56 am

Re: Capture problem in 256 color / palette mode

Post by ramiro »

Where did you find this pre-historic box? Paint Shop Pro 5, Delphi 5, Total Commander, Quake, mIRC, Worms Armageddon! It brings back memories...

Anyways, as to the actual problem, I can't really help =). If it was in rgb555 it might have been a known bug which I'm too lazy to fix, but it seems the input source is detected as bgr24 (is that correct?). This might be a bug in UScreenCapture, try capturing with another dshow-capable program (like VLC) and the same video input (UScreenCapture).

ramiro
Posts: 157
Joined: Tue May 10, 2011 12:56 am

Re: Capture problem in 256 color / palette mode

Post by ramiro »

hm, it might also be that the screen changes size and format, but ffmpeg doesn't know that. I've never thought about detecting changes in size/format.

prux
Posts: 3
Joined: Sun Nov 13, 2011 8:36 pm

Re: Capture problem in 256 color / palette mode

Post by prux »

there are better Paint Shop Pros, I just so got used PsP5.
I tried it with another capturer (WHscrCap), its the same.... and I havent found another capturer yet.
if I make a wait, so that capturing starts when program runs, its still the same.....
But thanx for the answer :roll:

prux
Posts: 3
Joined: Sun Nov 13, 2011 8:36 pm

Re: Capture problem in 256 color / palette mode

Post by prux »

just to point it out, the same happens with VCL too :D

Post Reply