ffmpeg no longer works under Windows XP (possible suspect identified)

Any other question that don't fit into the other support categorizes.
Reino
Posts: 90
Joined: Thu Aug 22, 2013 5:14 pm
Contact:

Re: ffmpeg no longer works under Windows XP (possible suspect identified)

Post by Reino » Sun Mar 27, 2016 11:00 am

2225936589 wrote:There are three similar functions also need to be modified
Could you be more specific?

cdlvcdlv
Posts: 19
Joined: Tue Mar 15, 2016 9:55 am

Re: ffmpeg no longer works under Windows XP (possible suspect identified)

Post by cdlvcdlv » Sun Apr 03, 2016 11:11 pm

CoRoNe wrote:
2225936589 wrote:There are three similar functions also need to be modified
Could you be more specific?
I've modified scanf_s, strncpy_s and _wfopen_s in ffmpeg, ffplay and ffprobe with HxD and they work (for now). I use XP Pro x64 with x64 builds (ffmpeg-20160401-git-b3eda69-win64-static).

Does anybody know a tool to replace the three strings in the three binaries? It would be nice to run a script after every update.
Edit:
I thought I had replaced swscanf_s, but it seems I only replaced this three strings. By the way, I answer myself: I found a powerful little utility (http://swissfileknife.sourceforge.net/) that can replace the strings from a batch file. I opened a thread with the details.
Making last version of FFmpeg work under XP

priitp
Posts: 1
Joined: Mon May 02, 2016 4:48 pm

Re: ffmpeg no longer works under Windows XP (possible suspect identified)

Post by priitp » Mon May 02, 2016 4:56 pm

Thank you for that wonderful patch.

It seems to me that this patch doesn't work on new ffmpeg builds.
Last I got patched was: ffmpeg-20160227-git-5156578-win32-static.
Next one ffmpeg-20160301-git-1c7e2cf-win32-static does not work any more.
Also tested without success on some random newer versions.
May be I'm doing something wrong.

Thanks
Priit Poldmaa

cdlvcdlv
Posts: 19
Joined: Tue Mar 15, 2016 9:55 am

Re: ffmpeg no longer works under Windows XP (possible suspect identified)

Post by cdlvcdlv » Sat May 14, 2016 5:55 pm

priitp wrote:Thank you for that wonderful patch.

It seems to me that this patch doesn't work on new ffmpeg builds.
Last I got patched was: ffmpeg-20160227-git-5156578-win32-static.
Next one ffmpeg-20160301-git-1c7e2cf-win32-static does not work any more.
Also tested without success on some random newer versions.
May be I'm doing something wrong.

Thanks
Priit Poldmaa
It seems you are not patching any file: ffmpeg-20160227-git-5156578-win32-static does not need patching for it's the last build that works in XP. The next build does need patching so it won't work without the fix.

Anyway, read carefully the instructions in the following thread:
Making last version of FFmpeg work under XP

Please post any further problem there, not here, so other users can read all about this topic in the same thread.

Post Reply
'