Making Zeranoe builds work under XP & XP builds by rogerdpack

Any other question that don't fit into the other support categorizes.
CoRoNe
Posts: 58
Joined: Thu Aug 22, 2013 5:14 pm
Contact:

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by CoRoNe » Fri Apr 06, 2018 9:31 pm

pablorosatti wrote:
Tue Apr 03, 2018 9:31 am
Hi! Can you build the last ffmpeg with AV1 support?
I will make a new build soon.
pablorosatti wrote:
Tue Apr 03, 2018 9:31 am
I have another question, there is a patch to make xp-compatible a non-XP compatible binary?
Why would you wanna ask such a question in a thread like this? Obviously no.
The fact that my build works on WinXP doesn't mean it won't work on Win7 and up. But then you're better off using Zeranoe's builds anyway.

manolito
Posts: 34
Joined: Wed Apr 20, 2016 4:02 pm

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by manolito » Wed Apr 11, 2018 6:38 am

Could it be that CoRoNe just misinterpreted this request?
I have another question, there is a patch to make xp-compatible a non-XP compatible binary?
I think what Pablo really meant to ask was this:
I have another question, there is a patch to make a non-XP compatible binary xp-compatible?
Just go the the first posts of this thread. There used to be such a patch, but it is no longer working.

Since rogerdpack gave up on creating XP compatible builds, my preferred builds currently are the one by CoRoNe and another one by Sherpya. Latest builds from March 24 are here:
https://sourceforge.net/projects/mplaye ... b2a7c947e/


Cheers
manolito

CoRoNe
Posts: 58
Joined: Thu Aug 22, 2013 5:14 pm
Contact:

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by CoRoNe » Sun Apr 15, 2018 2:54 pm

Fresh win32 builds:
ffmpeg-N-90713-g955fa23-win32-static_legacy.7z
ffmpeg-N-90713-g955fa23-win32-shared_legacy.7z
libfdk-aac-x86-v0.1.6_legacy.7z ('libfdk-aac-1.dll')
frei0r-plugins-x86-v1.6.1-11-g4b363c6_legacy.7z
openssl-x86-v1.0.2o_legacy.7z ('libeay32.dll', 'ssleay32.dll')
openssl-x86-v1.1.0h_legacy.7z ('libcrypto-1_1.dll', 'libssl-1_1.dll')

Changelog:

Code: Select all

ffmpeg-N-89661-ge45f7bc   --> ffmpeg-N-90713-g955fa23
mingw-w64-build-r23.local --> mingw-w64-build-r24.local (most notably GCC 7.2.0 --> 7.3.0)
SDL2-2.0.7                --> SDL2-2.0.8
freetype-2.8.1            --> freetype-2.9
libxml2-2.9.7             --> libxml2-2.9.8
fontconfig-2.12.6         --> fontconfig-2.13
nettle-3.3                --> nettle-3.4
gnutls-3.6.1              --> gnutls-3.6.2
mpg123-1.25.8             --> mpg123-1.25.10
libopenmpt-0.3.4          --> libopenmpt-0.3.8
                          --> tesseract_git (b7b6b28)
                          --> libaom_git
all other libraries       --> latest git

openssl-1.0.2n --> openssl-1.0.2o
openssl-1.1.0g --> openssl-1.1.0h
Unlike last time I'll now also gradually push the changes to my repo.

manolito
Posts: 34
Joined: Wed Apr 20, 2016 4:02 pm

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by manolito » Mon Apr 16, 2018 10:22 am

Thanks a lot, CoRoNe, works beautifully... :mrgreen:

The static version is flawless, the shared version shows the same behavior under DVDStyler as the previous build. No big deal...

Thanks again
manolito

CoRoNe
Posts: 58
Joined: Thu Aug 22, 2013 5:14 pm
Contact:

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by CoRoNe » Thu Apr 26, 2018 4:46 pm

Fresh win32 builds:
ffmpeg-N-90853-g3914a76

The latest binutils v2.30 (in the MingW build script) caused FFmpeg to crash when using -c:v libx265, so reverted to v2.29.1.

manolito
Posts: 34
Joined: Wed Apr 20, 2016 4:02 pm

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by manolito » Fri Apr 27, 2018 12:03 pm

Tested, works, thanks... :mrgreen:

User avatar
Zeranoe
Site Admin
Posts: 689
Joined: Sat May 07, 2011 7:12 pm
Contact:

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by Zeranoe » Fri May 04, 2018 12:15 am

Note that FFmpeg has dropped support for XP upstream.

CoRoNe
Posts: 58
Joined: Thu Aug 22, 2013 5:14 pm
Contact:

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by CoRoNe » Fri May 04, 2018 10:18 am

I'm well aware of that and I don't know how much longer I can keep this up, but we'll see.

It's probably some new SSE2 code, but do you know by any chance what particular change between binutils 2.29.1 and 2.30 could cause this crash?

User avatar
Zeranoe
Site Admin
Posts: 689
Joined: Sat May 07, 2011 7:12 pm
Contact:

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by Zeranoe » Sat May 05, 2018 7:28 am

I've had issues with 2.30 as well, best to hold off for a bit.

Yagiza
Posts: 3
Joined: Tue May 23, 2017 2:05 am

Re: Making Zeranoe builds work under XP & XP builds by rogerdpack

Post by Yagiza » Tue May 15, 2018 4:31 am

CoRoNe wrote:
Fri May 04, 2018 10:18 am
I'm well aware of that and I don't know how much longer I can keep this up, but we'll see.
Thank you for great work you are doing!

Post Reply