enable libass

Website, builds, or other suggestions.
nille02
Posts: 24
Joined: Tue Aug 14, 2012 3:47 pm

Re: enable libass

Post by nille02 » Tue Aug 14, 2012 7:29 pm

Sorry for multible Posting. So i have now compiles ffmpeg for Windows with cygwin ( because it was much easyer as with mingw or cross-compile under Linux for me )

So if you compile libass with --disable-fontconfig the hole libary is more or less useless because you cant burn-in the subtitel. After recompile libass with fontconfig support everything is fine.

NODE: and if you do that, please compile libass also with harfbuzz.

rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: enable libass

Post by rogerdpack » Wed Aug 15, 2012 7:15 pm

What if you specify a full path to a font in the .ass file?

nille02
Posts: 24
Joined: Tue Aug 14, 2012 3:47 pm

Re: enable libass

Post by nille02 » Wed Aug 15, 2012 8:29 pm

rogerdpack wrote:What if you specify a full path to a font in the .ass file?
Also no success. Even with the Default font: Arial.

In my opinion, without fontconfig, the libass support is useless.

User avatar
Zeranoe
Site Admin
Posts: 703
Joined: Sat May 07, 2011 7:12 pm
Contact:

Re: enable libass

Post by Zeranoe » Thu Aug 16, 2012 1:36 am

nille02 wrote:
rogerdpack wrote:What if you specify a full path to a font in the .ass file?
Also no success. Even with the Default font: Arial.

In my opinion, without fontconfig, the libass support is useless.
I added fontconfig support. Please test the latest build: git-f0896a6 (2012-08-16)

Thanks for the report.

nille02
Posts: 24
Joined: Tue Aug 14, 2012 3:47 pm

Re: enable libass

Post by nille02 » Thu Aug 16, 2012 1:54 am

Zeranoe wrote:I added fontconfig support. Please test the latest build: git-f0896a6 (2012-08-16)
Now he cant find the default fontconfig config file :/ and nothing is drawed.

EDIT: finally i fix the problem. you must create an folder called "fonts" in the folder where i run ffmpeg (e.g. F:\workspace\videos and not where the ffmpeg exe is saved ).
i hope i can set this with an env var to an other place

this is an default config file for fontconfig
Attachments
fonts.zip
(1.82 KiB) Downloaded 1731 times

rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: enable libass

Post by rogerdpack » Thu Aug 16, 2012 12:34 pm

So was fontconfig useful in the end? Is that what you basically used?

nille02
Posts: 24
Joined: Tue Aug 14, 2012 3:47 pm

Re: enable libass

Post by nille02 » Thu Aug 16, 2012 12:48 pm

rogerdpack wrote:So was fontconfig useful in the end?
Yes. Now everything work (more or less) like intended.

Thank you all for the help and the quick fix.

nille02
Posts: 24
Joined: Tue Aug 14, 2012 3:47 pm

Re: enable libass

Post by nille02 » Sat Aug 18, 2012 12:12 pm

I have searched an bit about the config file Location. With --with-baseconfigdir (e.g --with-baseconfigdir=%LOCALAPPDATA\fontconfig ) you can set the default path to the config file.

Or you can add the Systemfontdir ( Windows default C:\Windows\Fonts or %windir%\Fonts ) with "--with-default-fonts=" and the current folder with "--with-add-fonts=./".

The benefits from this is that we don't need the config file for an working fontconfig.

EDIT: Never mind this Post. You has only to set the Env Variable FC_CONFIG_DIR and FC_CONFIG_FILE

rogerdpack
Posts: 1877
Joined: Fri Aug 05, 2011 9:56 pm

Re: enable libass

Post by rogerdpack » Mon Aug 20, 2012 3:33 pm

This is at runtime? Could you create a detailed how to sometime?
-r

nille02
Posts: 24
Joined: Tue Aug 14, 2012 3:47 pm

Re: enable libass

Post by nille02 » Mon Aug 20, 2012 3:57 pm

except the env vars ( FC_CONFIG_DIR and FC_CONFIG_FILE ) everything are compile options for fontconfig.

So that fontconfig can proper work you has to set 2 environment variables. The First is FC_CONFIG_DIR with the Path where you place the config File. The second is FC_CONFIG_FILE with the full path and filename from the config file.

This is my example.
FC_CONFIG_DIR=F:\Work Area\ffmpeg64\bin\fonts
FC_CONFIG_FILE=F:\Work Area\ffmpeg64\bin\fonts\fonts.conf

If fontconfig can't find an valid configuration file you can't use the ass video filter

Thats why i suggest to compile fontconfig with the default path for windows, where he can find the fonts (include the current path ./ ).

Post Reply
'