Search found 10 matches

by FAyuso
Tue Feb 06, 2018 9:27 am
Forum: Developement with FFmpeg
Topic: Linking error (unresolved external symbol __HUGE)
Replies: 2
Views: 1425

Re: Linking error (unresolved external symbol __HUGE)

I have retried with version 3.4.1 with the same results :?
by FAyuso
Thu Dec 21, 2017 11:10 am
Forum: Developement with FFmpeg
Topic: Linking error (unresolved external symbol __HUGE)
Replies: 2
Views: 1425

Re: Linking error (unresolved external symbol __HUGE)

I'm still stuck with this problem :roll:
by FAyuso
Fri Nov 17, 2017 12:17 pm
Forum: Developement with FFmpeg
Topic: Linking error (unresolved external symbol __HUGE)
Replies: 2
Views: 1425

Linking error (unresolved external symbol __HUGE)

I'm trying to use new ffmpeg 3.4 in my project because I have been using ffmpeg 3.2 till now After some problems compiling it for Visual Studio 10, I finally did succesfuly. My problem now is using this libs in my project. Old libs works fine, but if I use the new ones I have the following linking e...
by FAyuso
Mon Jul 11, 2016 11:25 am
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Re: Error compiling ffmpeg 3.0 "Einstein"

After posting my problem to the ffmpeg-libav mailing list, the solution is to add Secur32.lib to my Visual Studio project.

I don't know what they have changed, but now, we need add this lib to our project.

Thanks for all!
by FAyuso
Fri Jul 08, 2016 8:47 am
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Re: Error compiling ffmpeg 3.0 "Einstein"

Good news!!!! New version (FFmpeg 3.1.1 "Laplace") compiles OK (I don't change anything in my old scripts). Only thing I can observe is that I have to use --disable-network in the configure step (I don't really know why). If I don't use this option, ffmpeg compiles but when I try to use the librarie...
by FAyuso
Mon May 09, 2016 7:23 am
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Re: Error compiling ffmpeg 3.0 "Einstein"

FFmpeg 3.0.2 does not work neither.

Any one could help?
by FAyuso
Tue Mar 29, 2016 9:08 am
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Re: Error compiling ffmpeg 3.0 "Einstein"

We have just downloaded the new version FFmpeg 3.0.1 "Einstein" and our problem persists.

Could anyone help us? Please!
by FAyuso
Tue Mar 08, 2016 8:27 am
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Re: Error compiling ffmpeg 3.0 "Einstein"

Taha wrote:You can try one thing, do #define HAVE_FAST_CLZ 0 manually in config.h. May be it will work.
Ok, changing to 0 compiles, but when we try to compile our solution, a lot of link errors appear. So, we think it is not a solution.
by FAyuso
Wed Feb 24, 2016 9:10 am
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Re: Error compiling ffmpeg 3.0 "Einstein"

I have used KDiff to see differences between 2.8.6 and 3.0 version. In libavutil/x86/intmath.h, version 3.0 has defined: #if HAVE_FAST_CLZ #if (defined(__INTEL_COMPILER) && (__INTEL_COMPILER>=1216)) || defined(_MSC_VER) # if defined(__INTEL_COMPILER) # define ff_log2(x) (_bit_scan_reverse((x)|1)) # ...
by FAyuso
Tue Feb 16, 2016 12:16 pm
Forum: Compiling
Topic: Error compiling ffmpeg 3.0 "Einstein"
Replies: 8
Views: 4904

Error compiling ffmpeg 3.0 "Einstein"

I've just downloaded the latest version of ffmpeg and I'm trying to compile it in Windows 7 using Visual Studio 2010. I usually use mingw, C99-to-C89 Converter and yasm. In previous versions, I used some scripts to compile and it worked perfectly. Now, I'm having some troubles. After ./configure --t...
'