Search found 35 matches

by iotzo
Thu Dec 04, 2014 1:09 pm
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

Ok, no error on -list_devices and no COM error. But did you try to output something? Lates zeranoe build (git-5fe026f) which include Jonathan's patch still not working for me :( [decklink @ 02f7e980] Could not open output device from 'DeckLink SP' No error with previous versions. Am I Doing Somethi...
by iotzo
Wed Dec 03, 2014 6:29 pm
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

Thank you people! :)
Jbalvarado - for Your dedication and Ramiro for Your patience:)
by iotzo
Wed Dec 03, 2014 11:47 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

Oops! I think I misread your question, but it doesn't hurt to have the change on line 51 too.
by iotzo
Wed Dec 03, 2014 9:37 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

jbalvarado wrote:Thank you! Is in line 51 the same?

Code: Select all

IID_IDeckLinkIterator, (void**) &iter) != S_OK)
Yes!
by iotzo
Wed Dec 03, 2014 8:57 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

jbalvarado wrote:Nice! Can you please write me here the correct line?

Normally I'm the wrong person for posting patches, because I am not a programmer... ;)

Code: Select all

    if (CoInitialize(NULL) < 0 ) {
by iotzo
Wed Dec 03, 2014 8:47 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

jbalvarado wrote:The second patch they can not use. I was getting this message:
This code is Copyright (c) Blackmagic Design. Try just changing the check for CoInitialize(NULL) from "!= S_OK" to "< 0".
Just tested it and it works!
Thank You people!
by iotzo
Wed Dec 03, 2014 8:46 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

To get the proper files with widl, I compiled mingw-w64 from source. You can use Zeranoe's build script for this. *but* you have to patch widl with this patch http://pastebin.com/7z2vYNNq Then, remove references to stdole2.tlb and generate the files: $ sed s/'importlib("stdole2.tlb");'// -i * $ wid...
by iotzo
Wed Dec 03, 2014 8:41 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

jbalvarado wrote:I have send now two patches to the malling list.

The widl command is not complete I think. It must be like this:
widl -I/mingw32/i686-w64-mingw32/include -h -u -o DeckLinkAPI.h DeckLinkAPI.idl
I see, thanks!
by iotzo
Tue Dec 02, 2014 12:19 pm
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

Yes that is a bit bad, you need this file and some other from the source code: http://sourceforge.net/projects/mingw-w64/files/mingw-w64/mingw-w64-release/ here under headers/include I think they are. This files you need to copy to \mingw32\i686-w64-mingw32\include for 64 bit you need to change. Th...
by iotzo
Tue Dec 02, 2014 8:44 am
Forum: Suggestions
Topic: DeckLink output --enable-decklink
Replies: 56
Views: 48000

Re: DeckLink output --enable-decklink

Hm, crazy. You are right, the patch is not complete. I need to fix that... Edit: Ah yes, I post the a old patch :(... Is not good to do something in a hurry. Btw, I am using your wonderful media-autobuild_suite and i struggle to get DeckLinkAPI.h from .idl via widl: widl sh: widl: command not found...
'